#include <MsgBoxConstants.au3> ; to declare the Constants of MsgBox
Local $sRegex = "[A-Z]+(\d+)_[A-Z]+_[A-Z]+"
Local $sString = "BREAK1_UPPER_QUANTITY"
Local $sSubst = "Staffel \1 Obergrenze"
Local $sResult = StringRegExpReplace($sString, $sRegex, $sSubst)
MsgBox($MB_SYSTEMMODAL, "Result", $sResult)