import re
regex = re.compile(r"[A-Z]+(\d+)_[A-Z]+_[A-Z]+")
test_str = "BREAK1_UPPER_QUANTITY"
subst = "Staffel \\1 Obergrenze"
result = regex.sub(subst, test_str, count=1)
if result:
print(result)