using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"[A-Z]+(\d+)_[A-Z]+_[A-Z]+";
string substitution = @"Staffel \1 Obergrenze";
string input = @"BREAK1_UPPER_QUANTITY";
Regex regex = new Regex(pattern);
string result = regex.Replace(input, substitution, 1);
}
}