use strict;
my $str = 'BREAK1_UPPER_QUANTITY';
my $regex = qr/[A-Z]+(\d+)_[A-Z]+_[A-Z]+/p;
my $subst = 'Staffel \\1 Obergrenze';
my $result = $str =~ s/$regex/$subst/r;
print "The result of the substitution is' $result\n";