#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m)(?s)\|\s*eval\s+(?<field>\w+)\s*=\s*(?<data>([^\"]|\"(\\\\|\\\"|[^\"])+\"[^\"])+?)(?=\s*\|)"
Local $sString = "| eval var=case(" & @CRLF & _
" a,b," & @CRLF & _
" c,d," & @CRLF & _
" e,f)" & @CRLF & _
"| eval var2=case(" & @CRLF & _
" match(x, "z|y|z"), 1," & @CRLF & _
" match(x, "a|b|c"), 2)" & @CRLF & _
"| eval var3=case(" & @CRLF & _
" match(x, "z|\"y|z\\\""), 1," & @CRLF & _
" match(x, "a|b|c"), 2)| eval var4=case(" & @CRLF & _
" match(x, "z|y|z"), 1," & @CRLF & _
" match(x, "a|b|c"), 2)" & @CRLF & _
"|"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")