use strict;
my $str = '| eval var=case(
a,b,
c,d,
e,f)
| eval var2=case(
match(x, "z|y|z"), 1,
match(x, "a|b|c"), 2)
| eval var3=case(
match(x, "z|\\"y|z\\\\\\""), 1,
match(x, "a|b|c"), 2)| eval var4=case(
match(x, "z|y|z"), 1,
match(x, "a|b|c"), 2)
|';
my $regex = qr/(?s)\|\s*eval\s+(?<field>\w+)\s*=\s*(?<data>([^\"]|\"(\\\\|\\\"|[^\"])+\"[^\"])+?)(?=\s*\|)/mp;
if ( $str =~ /$regex/g ) {
print "Whole match is ${^MATCH} and its start/end positions can be obtained via \$-[0] and \$+[0]\n";
# print "Capture Group 1 is $1 and its start/end positions can be obtained via \$-[1] and \$+[1]\n";
# print "Capture Group 2 is $2 ... and so on\n";
}
# ${^POSTMATCH} and ${^PREMATCH} are also available with the use of '/p'
# Named capture groups can be called via $+{name}