using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"(?s)\|\s*eval\s+(?<field>\w+)\s*=\s*(?<data>([^\""]|\""(\\\\|\\\""|[^\""])+\""[^\""])+?)(?=\s*\|)";
string input = @"| eval var=case(
a,b,
c,d,
e,f)
| eval var2=case(
match(x, ""z|y|z""), 1,
match(x, ""a|b|c""), 2)
| eval var3=case(
match(x, ""z|\""y|z\\\""), 1,
match(x, ""a|b|c""), 2)| eval var4=case(
match(x, ""z|y|z""), 1,
match(x, ""a|b|c""), 2)
|";
RegexOptions options = RegexOptions.Multiline;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}