import Foundation
let pattern = #"(?s)\|\s*eval\s+(?<field>\w+)\s*=\s*(?<data>([^\"]|\"(\\\\|\\\"|[^\"])+\"[^\"])+?)(?=\s*\|)"#
let regex = try! NSRegularExpression(pattern: pattern, options: .anchorsMatchLines)
let testString = #"""
| eval var=case(
a,b,
c,d,
e,f)
| eval var2=case(
match(x, "z|y|z"), 1,
match(x, "a|b|c"), 2)
| eval var3=case(
match(x, "z|\"y|z\\\""), 1,
match(x, "a|b|c"), 2)| eval var4=case(
match(x, "z|y|z"), 1,
match(x, "a|b|c"), 2)
|
"""#
let stringRange = NSRange(location: 0, length: testString.utf16.count)
let matches = regex.matches(in: testString, range: stringRange)
var result: [[String]] = []
for match in matches {
var groups: [String] = []
for rangeIndex in 1 ..< match.numberOfRanges {
let nsRange = match.range(at: rangeIndex)
guard !NSEqualRanges(nsRange, NSMakeRange(NSNotFound, 0)) else { continue }
let string = (testString as NSString).substring(with: nsRange)
groups.append(string)
}
if !groups.isEmpty {
result.append(groups)
}
}
print(result)