# coding=utf8
# the above tag defines encoding for this document and is for Python 2.x compatibility
import re
regex = r"(?s)\|\s*eval\s+(?<field>\w+)\s*=\s*(?<data>([^\"]|\"(\\\\|\\\"|[^\"])+\"[^\"])+?)(?=\s*\|)"
test_str = ("| eval var=case(\n"
" a,b,\n"
" c,d,\n"
" e,f)\n"
"| eval var2=case(\n"
" match(x, \"z|y|z\"), 1,\n"
" match(x, \"a|b|c\"), 2)\n"
"| eval var3=case(\n"
" match(x, \"z|\\\"y|z\\\\\\\"\"), 1,\n"
" match(x, \"a|b|c\"), 2)| eval var4=case(\n"
" match(x, \"z|y|z\"), 1,\n"
" match(x, \"a|b|c\"), 2)\n"
"|")
matches = re.finditer(regex, test_str, re.MULTILINE)
for matchNum, match in enumerate(matches, start=1):
print ("Match {matchNum} was found at {start}-{end}: {match}".format(matchNum = matchNum, start = match.start(), end = match.end(), match = match.group()))
for groupNum in range(0, len(match.groups())):
groupNum = groupNum + 1
print ("Group {groupNum} found at {start}-{end}: {group}".format(groupNum = groupNum, start = match.start(groupNum), end = match.end(groupNum), group = match.group(groupNum)))
# Note: for Python 2.7 compatibility, use ur"" to prefix the regex and u"" to prefix the test string and substitution.