use strict;
my $str = 'ABCD123
';
my $regex = qr/([A-Za-z.\/-]+)|([^A-Za-z.\/-]+)/p;
my $subst = '';
my $result = $str =~ s/$regex/$subst/rg;
print "The result of the substitution is' $result\n";