import re
regex = re.compile(r"([A-Za-z.\/-]+)|([^A-Za-z.\/-]+)")
test_str = ("ABCD123\n\n")
subst = ""
result = regex.sub(subst, test_str)
if result:
print(result)