import Foundation
let pattern = #"([A-Za-z.\/-]+)|([^A-Za-z.\/-]+)"#
let regex = try! NSRegularExpression(pattern: pattern)
let testString = #"""
ABCD123
"""#
let stringRange = NSRange(location: 0, length: testString.utf16.count)
let substitutionString = #""#
let result = regex.stringByReplacingMatches(in: testString, range: stringRange, withTemplate: substitutionString)
print(result)