package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?i)((?:https?:\/\/)?(?:www\.)?(?:rpgmakermv|rmmv)\.co)`)
var str = `rpgmakermv.co
www.rpgmakermv.co
http://rpgmakermv.co
https://rpgmakermv.co
http://www.rpgmakermv.co
https://www.rpgmakermv.co
rmmv.co
www.rmmv.co
http://rmmv.co
https://rmmv.co
http://www.rmmv.co
https://www.rmmv.co`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}