re = /((?:https?:\/\/)?(?:www\.)?(?:rpgmakermv|rmmv)\.co)/i
str = 'rpgmakermv.co
www.rpgmakermv.co
http://rpgmakermv.co
https://rpgmakermv.co
http://www.rpgmakermv.co
https://www.rpgmakermv.co
rmmv.co
www.rmmv.co
http://rmmv.co
https://rmmv.co
http://www.rmmv.co
https://www.rmmv.co'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end