# coding=utf8
# the above tag defines encoding for this document and is for Python 2.x compatibility
import re
regex = r"((?:https?:\/\/)?(?:www\.)?(?:rpgmakermv|rmmv)\.co)"
test_str = ("rpgmakermv.co\n"
"www.rpgmakermv.co\n"
"http://rpgmakermv.co\n"
"https://rpgmakermv.co\n"
"http://www.rpgmakermv.co\n"
"https://www.rpgmakermv.co\n\n"
"rmmv.co\n"
"www.rmmv.co\n"
"http://rmmv.co\n"
"https://rmmv.co\n"
"http://www.rmmv.co\n"
"https://www.rmmv.co")
matches = re.finditer(regex, test_str, re.IGNORECASE)
for matchNum, match in enumerate(matches, start=1):
print ("Match {matchNum} was found at {start}-{end}: {match}".format(matchNum = matchNum, start = match.start(), end = match.end(), match = match.group()))
for groupNum in range(0, len(match.groups())):
groupNum = groupNum + 1
print ("Group {groupNum} found at {start}-{end}: {group}".format(groupNum = groupNum, start = match.start(groupNum), end = match.end(groupNum), group = match.group(groupNum)))
# Note: for Python 2.7 compatibility, use ur"" to prefix the regex and u"" to prefix the test string and substitution.