const regex = /((?:https?:\/\/)?(?:www\.)?(?:rpgmakermv|rmmv)\.co)/gi;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('((?:https?:\\\/\\\/)?(?:www\\.)?(?:rpgmakermv|rmmv)\\.co)', 'gi')
const str = `rpgmakermv.co
www.rpgmakermv.co
http://rpgmakermv.co
https://rpgmakermv.co
http://www.rpgmakermv.co
https://www.rpgmakermv.co
rmmv.co
www.rmmv.co
http://rmmv.co
https://rmmv.co
http://www.rmmv.co
https://www.rmmv.co`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}