import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "((?:https?:\\/\\/)?(?:www\\.)?(?:rpgmakermv|rmmv)\\.co)";
final String string = "rpgmakermv.co\n"
+ "www.rpgmakermv.co\n"
+ "http://rpgmakermv.co\n"
+ "https://rpgmakermv.co\n"
+ "http://www.rpgmakermv.co\n"
+ "https://www.rpgmakermv.co\n\n"
+ "rmmv.co\n"
+ "www.rmmv.co\n"
+ "http://rmmv.co\n"
+ "https://rmmv.co\n"
+ "http://www.rmmv.co\n"
+ "https://www.rmmv.co";
final Pattern pattern = Pattern.compile(regex, Pattern.CASE_INSENSITIVE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}