using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"\033\[(?:\d+;\d+[Hf]|\d+[A-D]|[suK]|2J|\d+(?:;\d+)*m)";
string input = @"[K
[1;4;41;37m
[0m
[42A
[2J
[2;3H";
foreach (Match m in Regex.Matches(input, pattern))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}