re = /\033\[(?:\d+;\d+[Hf]|\d+[A-D]|[suK]|2J|\d+(?:;\d+)*m)/
str = '[K
[1;4;41;37m
[0m
[42A
[2J
[2;3H'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end