import re
regex = re.compile(r"\033\[(?:\d+;\d+[Hf]|\d+[A-D]|[suK]|2J|\d+(?:;\d+)*m)")
test_str = ("[K\n"
"[1;4;41;37m\n"
"[0m\n"
"[42A\n"
"[2J\n"
"[2;3H")
matches = regex.finditer(test_str)
for match_num, match in enumerate(matches, start=1):
print(f"Match {match_num} was found at {match.start()}-{match.end()}: {match.group()}")
for group_num, group in enumerate(match.groups(), start=1):
print(f"Group {group_num} found at {match.start(group_num)}-{match.end(group_num)}: {group}")