const regex = /\033\[(?:\d+;\d+[Hf]|\d+[A-D]|[suK]|2J|\d+(?:;\d+)*m)/g;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('\\033\\[(?:\\d+;\\d+[Hf]|\\d+[A-D]|[suK]|2J|\\d+(?:;\\d+)*m)', 'g')
const str = `[K
[1;4;41;37m
[0m
[42A
[2J
[2;3H`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}