#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(\S+)(\/[\w-]+\/[\w-]+\/videos\/[\d-]+\/\w+\.ts)"
Local $sString = "/share/CACHEDEV1_DATA/.qpkg/SolinkConnect/data/vms/1eq0U31IYNNWUOss/3ddf9e2c-46f6-40a0-e010-272d1a058369/videos/2016-1-9/1452345673000_15246.ts"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")