// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"(\S+)(\/[\w-]+\/[\w-]+\/videos\/[\d-]+\/\w+\.ts)").unwrap();
let string = "/share/CACHEDEV1_DATA/.qpkg/SolinkConnect/data/vms/1eq0U31IYNNWUOss/3ddf9e2c-46f6-40a0-e010-272d1a058369/videos/2016-1-9/1452345673000_15246.ts";
// result will be an iterator over tuples containing the start and end indices for each match in the string
let result = regex.captures_iter(string);
for mat in result {
println!("{:?}", mat);
}
}