import re
regex = re.compile(r"(\S+)(\/[\w-]+\/[\w-]+\/videos\/[\d-]+\/\w+\.ts)")
test_str = "/share/CACHEDEV1_DATA/.qpkg/SolinkConnect/data/vms/1eq0U31IYNNWUOss/3ddf9e2c-46f6-40a0-e010-272d1a058369/videos/2016-1-9/1452345673000_15246.ts"
matches = regex.finditer(test_str)
for match_num, match in enumerate(matches, start=1):
print(f"Match {match_num} was found at {match.start()}-{match.end()}: {match.group()}")
for group_num, group in enumerate(match.groups(), start=1):
print(f"Group {group_num} found at {match.start(group_num)}-{match.end(group_num)}: {group}")