import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "(\\S+)(\\/[\\w-]+\\/[\\w-]+\\/videos\\/[\\d-]+\\/\\w+\\.ts)";
final String string = "/share/CACHEDEV1_DATA/.qpkg/SolinkConnect/data/vms/1eq0U31IYNNWUOss/3ddf9e2c-46f6-40a0-e010-272d1a058369/videos/2016-1-9/1452345673000_15246.ts";
final Pattern pattern = Pattern.compile(regex);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}