import Foundation
let pattern = #"(\S+)(\/[\w-]+\/[\w-]+\/videos\/[\d-]+\/\w+\.ts)"#
let regex = try! NSRegularExpression(pattern: pattern)
let testString = #"/share/CACHEDEV1_DATA/.qpkg/SolinkConnect/data/vms/1eq0U31IYNNWUOss/3ddf9e2c-46f6-40a0-e010-272d1a058369/videos/2016-1-9/1452345673000_15246.ts"#
let stringRange = NSRange(location: 0, length: testString.utf16.count)
let matches = regex.matches(in: testString, range: stringRange)
var result: [[String]] = []
for match in matches {
var groups: [String] = []
for rangeIndex in 1 ..< match.numberOfRanges {
let nsRange = match.range(at: rangeIndex)
guard !NSEqualRanges(nsRange, NSMakeRange(NSNotFound, 0)) else { continue }
let string = (testString as NSString).substring(with: nsRange)
groups.append(string)
}
if !groups.isEmpty {
result.append(groups)
}
}
print(result)