#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m)^(#{3})([t\f\v \u00a0\u1680\u2000-\u200a\u2028\u2029\u202f\u205f\u3000\ufeff]+([^\n\r]+)+|([^\s\n#])+)$"
Local $sString = "# Алиса" & @CRLF & _
"## Бобик" & @CRLF & _
"### Рыжик" & @CRLF & _
"#### Маруся" & @CRLF & _
"" & @CRLF & _
"#Алиса" & @CRLF & _
"##Бобик" & @CRLF & _
"###Рыжик" & @CRLF & _
"####Маруся"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")