$re = '/^(#{3})([t\f\v \u00a0\u1680\u2000-\u200a\u2028\u2029\u202f\u205f\u3000\ufeff]+([^\n\r]+)+|([^\s\n#])+)$/m';
$str = '# Алиса
## Бобик
### Рыжик
#### Маруся
#Алиса
##Бобик
###Рыжик
####Маруся';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);