import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "^(#{3})([t\\f\\v \\u00a0\\u1680\\u2000-\\u200a\\u2028\\u2029\\u202f\\u205f\\u3000\\ufeff]+([^\\n\\r]+)+|([^\\s\\n#])+)$";
final String string = "# Алиса\n"
+ "## Бобик\n"
+ "### Рыжик\n"
+ "#### Маруся\n\n"
+ "#Алиса\n"
+ "##Бобик\n"
+ "###Рыжик\n"
+ "####Маруся";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}