package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)^(#{3})([t\f\v \u00a0\u1680\u2000-\u200a\u2028\u2029\u202f\u205f\u3000\ufeff]+([^\n\r]+)+|([^\s\n#])+)$`)
var str = `# Алиса
## Бобик
### Рыжик
#### Маруся
#Алиса
##Бобик
###Рыжик
####Маруся`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}