import re
regex = re.compile(r"^(#{3})([t\f\v \u00a0\u1680\u2000-\u200a\u2028\u2029\u202f\u205f\u3000\ufeff]+([^\n\r]+)+|([^\s\n#])+)$", flags=re.MULTILINE)
test_str = ("# Алиса\n"
"## Бобик\n"
"### Рыжик\n"
"#### Маруся\n\n"
"#Алиса\n"
"##Бобик\n"
"###Рыжик\n"
"####Маруся")
matches = regex.finditer(test_str)
for match_num, match in enumerate(matches, start=1):
print(f"Match {match_num} was found at {match.start()}-{match.end()}: {match.group()}")
for group_num, group in enumerate(match.groups(), start=1):
print(f"Group {group_num} found at {match.start(group_num)}-{match.end(group_num)}: {group}")