package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(www\.|http://)([a-zA-Z0-9\/?\-&=_\.]+\.com|\.net|\.org|\.ca)(/[a-zA-Z0-9/?\-_&=\.]*)?`)
var str = `This is a stupid site: www.etsy.com and etc
This is a stupid video http://www.youtube.com/watch?v=MkXVM6ad9nI and etc`
var substitution = "<a href='$1$2$3'>$1$2$3</a>"
fmt.Println(re.ReplaceAllString(str, substitution))
}