// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"(www\.|http://)([a-zA-Z0-9\/?\-&=_\.]+\.com|\.net|\.org|\.ca)(/[a-zA-Z0-9/?\-_&=\.]*)?").unwrap();
let string = "This is a stupid site: www.etsy.com and etc
This is a stupid video http://www.youtube.com/watch?v=MkXVM6ad9nI and etc";
let substitution = "<a href='$1$2$3'>$1$2$3</a>";
// result will be a String with the substituted value
let result = regex.replace_all(string, substitution);
println!("{}", result);
}