const regex = new RegExp('(www\\.|http://)([a-zA-Z0-9\\/?\\-&=_\\.]+\\.com|\\.net|\\.org|\\.ca)(/[a-zA-Z0-9/?\\-_&=\\.]*)?', 'g')
const str = `This is a stupid site: www.etsy.com and etc
This is a stupid video http://www.youtube.com/watch?v=MkXVM6ad9nI and etc`;
const subst = `<a href='$1$2$3'>$1$2$3</a>`;
// The substituted value will be contained in the result variable
const result = str.replace(regex, subst);
console.log('Substitution result: ', result);