import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "(www\\.|http://)([a-zA-Z0-9\\/?\\-&=_\\.]+\\.com|\\.net|\\.org|\\.ca)(/[a-zA-Z0-9/?\\-_&=\\.]*)?";
final String string = "This is a stupid site: www.etsy.com and etc\n"
+ "This is a stupid video http://www.youtube.com/watch?v=MkXVM6ad9nI and etc";
final String subst = "<a href='$1$2$3'>$1$2$3</a>";
final Pattern pattern = Pattern.compile(regex);
final Matcher matcher = pattern.matcher(string);
// The substituted value will be contained in the result variable
final String result = matcher.replaceAll(subst);
System.out.println("Substitution result: " + result);
}
}