#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "[AP]M[^a-zA-Z]-[^a-zA-Z]\S+[ ]?\S+[ ]?\S+:."
Local $sString = "4/16/14, 10:24 AM - Łuk123asz123 Sącz: How is everything going on? Check this: iPhone7!" & @CRLF & _
"4/16/14, 10:24 AM@-!John(@!^$*(&Doe: How is everything going on? Check this: iPhone7!" & @CRLF & _
"4/16/14, 10:24 AM#-$John("<asd>")Doe: How is everything going on? Check this: iPhone7!" & @CRLF & _
"4/16/14, 10:24 AM%-^John Doe: How is everything going on? Check this: iPhone7!" & @CRLF & _
"4/16/14, 10:24 AM&-*Łukasz Sącz: How is everything going on? Check this: iPhone7!" & @CRLF & _
"4/16/14, 10:24 AM9-)Сергей Макаровe: How is everything going on? Check this: iPhone7!" & @CRLF & _
"4/16/14, 10:24 AM--+John Doe: How is everything going on? Check this: iPhone7!" & @CRLF & _
"4/16/14, 10:24 AM_-=John Doe: How is everything going on? Check this: iPhone7!" & @CRLF & _
"4/16/14, 10:24 AM\-|John Doe: How is everything going on? Check this: iPhone7!" & @CRLF & _
"4/16/14, 10:24 AM]-}Сергей Макаров: How is everything going on? Check this: iPhone7!" & @CRLF & _
"4/16/14, 10:24 AM{-[John Doe: How is everything going on? Check this: iPhone7!" & @CRLF & _
"4/16/14, 10:24 AM'-"John Doe: How is everything going on? Check this: iPhone7!" & @CRLF & _
"4/16/14, 10:24 AM;-:John Doe: How is everything going on? Check this: iPhone7!" & @CRLF & _
"4/16/14, 10:24 AM,-<John Doe: How is everything going on? Check this: iPhone7!" & @CRLF & _
"4/16/14, 10:24 AM.->John Doe: How is everything going on? Check this: iPhone7!" & @CRLF & _
"4/16/14, 10:24 AM/-?John Doe: How is everything going on? Check this: iPhone7!"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")