$re = '/[AP]M[^a-zA-Z]-[^a-zA-Z]\S+[ ]?\S+[ ]?\S+:./';
$str = '4/16/14, 10:24 AM - Łuk123asz123 Sącz: How is everything going on? Check this: iPhone7!
4/16/14, 10:24 AM@-!John(@!^$*(&Doe: How is everything going on? Check this: iPhone7!
4/16/14, 10:24 AM#-$John("<asd>")Doe: How is everything going on? Check this: iPhone7!
4/16/14, 10:24 AM%-^John Doe: How is everything going on? Check this: iPhone7!
4/16/14, 10:24 AM&-*Łukasz Sącz: How is everything going on? Check this: iPhone7!
4/16/14, 10:24 AM9-)Сергей Макаровe: How is everything going on? Check this: iPhone7!
4/16/14, 10:24 AM--+John Doe: How is everything going on? Check this: iPhone7!
4/16/14, 10:24 AM_-=John Doe: How is everything going on? Check this: iPhone7!
4/16/14, 10:24 AM\\-|John Doe: How is everything going on? Check this: iPhone7!
4/16/14, 10:24 AM]-}Сергей Макаров: How is everything going on? Check this: iPhone7!
4/16/14, 10:24 AM{-[John Doe: How is everything going on? Check this: iPhone7!
4/16/14, 10:24 AM\'-"John Doe: How is everything going on? Check this: iPhone7!
4/16/14, 10:24 AM;-:John Doe: How is everything going on? Check this: iPhone7!
4/16/14, 10:24 AM,-<John Doe: How is everything going on? Check this: iPhone7!
4/16/14, 10:24 AM.->John Doe: How is everything going on? Check this: iPhone7!
4/16/14, 10:24 AM/-?John Doe: How is everything going on? Check this: iPhone7!';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);