// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"[AP]M[^a-zA-Z]-[^a-zA-Z]\S+[ ]?\S+[ ]?\S+:.").unwrap();
let string = "4/16/14, 10:24 AM - Łuk123asz123 Sącz: How is everything going on? Check this: iPhone7!
4/16/14, 10:24 AM@-!John(@!^$*(&Doe: How is everything going on? Check this: iPhone7!
4/16/14, 10:24 AM#-$John(\"<asd>\")Doe: How is everything going on? Check this: iPhone7!
4/16/14, 10:24 AM%-^John Doe: How is everything going on? Check this: iPhone7!
4/16/14, 10:24 AM&-*Łukasz Sącz: How is everything going on? Check this: iPhone7!
4/16/14, 10:24 AM9-)Сергей Макаровe: How is everything going on? Check this: iPhone7!
4/16/14, 10:24 AM--+John Doe: How is everything going on? Check this: iPhone7!
4/16/14, 10:24 AM_-=John Doe: How is everything going on? Check this: iPhone7!
4/16/14, 10:24 AM\\-|John Doe: How is everything going on? Check this: iPhone7!
4/16/14, 10:24 AM]-}Сергей Макаров: How is everything going on? Check this: iPhone7!
4/16/14, 10:24 AM{-[John Doe: How is everything going on? Check this: iPhone7!
4/16/14, 10:24 AM'-\"John Doe: How is everything going on? Check this: iPhone7!
4/16/14, 10:24 AM;-:John Doe: How is everything going on? Check this: iPhone7!
4/16/14, 10:24 AM,-<John Doe: How is everything going on? Check this: iPhone7!
4/16/14, 10:24 AM.->John Doe: How is everything going on? Check this: iPhone7!
4/16/14, 10:24 AM/-?John Doe: How is everything going on? Check this: iPhone7!";
// result will be an iterator over tuples containing the start and end indices for each match in the string
let result = regex.captures_iter(string);
for mat in result {
println!("{:?}", mat);
}
}