using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"[AP]M[^a-zA-Z]-[^a-zA-Z]\S+[ ]?\S+[ ]?\S+:.";
string input = @"4/16/14, 10:24 AM - Łuk123asz123 Sącz: How is everything going on? Check this: iPhone7!
4/16/14, 10:24 AM@-!John(@!^$*(&Doe: How is everything going on? Check this: iPhone7!
4/16/14, 10:24 AM#-$John(""<asd>"")Doe: How is everything going on? Check this: iPhone7!
4/16/14, 10:24 AM%-^John Doe: How is everything going on? Check this: iPhone7!
4/16/14, 10:24 AM&-*Łukasz Sącz: How is everything going on? Check this: iPhone7!
4/16/14, 10:24 AM9-)Сергей Макаровe: How is everything going on? Check this: iPhone7!
4/16/14, 10:24 AM--+John Doe: How is everything going on? Check this: iPhone7!
4/16/14, 10:24 AM_-=John Doe: How is everything going on? Check this: iPhone7!
4/16/14, 10:24 AM\-|John Doe: How is everything going on? Check this: iPhone7!
4/16/14, 10:24 AM]-}Сергей Макаров: How is everything going on? Check this: iPhone7!
4/16/14, 10:24 AM{-[John Doe: How is everything going on? Check this: iPhone7!
4/16/14, 10:24 AM'-""John Doe: How is everything going on? Check this: iPhone7!
4/16/14, 10:24 AM;-:John Doe: How is everything going on? Check this: iPhone7!
4/16/14, 10:24 AM,-<John Doe: How is everything going on? Check this: iPhone7!
4/16/14, 10:24 AM.->John Doe: How is everything going on? Check this: iPhone7!
4/16/14, 10:24 AM/-?John Doe: How is everything going on? Check this: iPhone7!";
foreach (Match m in Regex.Matches(input, pattern))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}