const regex = /[AP]M[^a-zA-Z]-[^a-zA-Z]\S+[ ]?\S+[ ]?\S+:./g;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('[AP]M[^a-zA-Z]-[^a-zA-Z]\\S+[ ]?\\S+[ ]?\\S+:.', 'g')
const str = `4/16/14, 10:24 AM - Łuk123asz123 Sącz: How is everything going on? Check this: iPhone7!
4/16/14, 10:24 AM@-!John(@!^\$*(&Doe: How is everything going on? Check this: iPhone7!
4/16/14, 10:24 AM#-\$John("<asd>")Doe: How is everything going on? Check this: iPhone7!
4/16/14, 10:24 AM%-^John Doe: How is everything going on? Check this: iPhone7!
4/16/14, 10:24 AM&-*Łukasz Sącz: How is everything going on? Check this: iPhone7!
4/16/14, 10:24 AM9-)Сергей Макаровe: How is everything going on? Check this: iPhone7!
4/16/14, 10:24 AM--+John Doe: How is everything going on? Check this: iPhone7!
4/16/14, 10:24 AM_-=John Doe: How is everything going on? Check this: iPhone7!
4/16/14, 10:24 AM\\-|John Doe: How is everything going on? Check this: iPhone7!
4/16/14, 10:24 AM]-}Сергей Макаров: How is everything going on? Check this: iPhone7!
4/16/14, 10:24 AM{-[John Doe: How is everything going on? Check this: iPhone7!
4/16/14, 10:24 AM'-"John Doe: How is everything going on? Check this: iPhone7!
4/16/14, 10:24 AM;-:John Doe: How is everything going on? Check this: iPhone7!
4/16/14, 10:24 AM,-<John Doe: How is everything going on? Check this: iPhone7!
4/16/14, 10:24 AM.->John Doe: How is everything going on? Check this: iPhone7!
4/16/14, 10:24 AM/-?John Doe: How is everything going on? Check this: iPhone7!`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}