#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?xs)" & @CRLF & _
"outer-start(?:(?!inner-start).)*?outer-end|" & @CRLF & _
"outer-start(?:(?!outer-end).)*?inner-end(?:(?!outer-end).)*?s\.*?outer-end|" & @CRLF & _
"inner-start\s*(text-that-i-want)\s*inner-end"
Local $sString = "outer-start some unwanted text inner-start text-that-i-want inner-end some more text outer-end" & @CRLF & _
"outer-start some text inner-start text-that-i-want inner-end some more unwanted text outer-end" & @CRLF & _
"outer-start some text inner-start text-that-i-want inner-end some more text outer-end" & @CRLF & _
"outer-start some text inner-start text-that-i-want inner-end some more unwanted text outer-end" & @CRLF & _
""
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")