# coding=utf8
# the above tag defines encoding for this document and is for Python 2.x compatibility
import re
regex = (r"(?xs)\n"
r"outer-start(?:(?!inner-start).)*?outer-end|\n"
r"outer-start(?:(?!outer-end).)*?inner-end(?:(?!outer-end).)*?s\.*?outer-end|\n"
r"inner-start\s*(text-that-i-want)\s*inner-end")
test_str = ("outer-start some unwanted text inner-start text-that-i-want inner-end some more text outer-end\n"
"outer-start some text inner-start text-that-i-want inner-end some more unwanted text outer-end\n"
"outer-start some text inner-start text-that-i-want inner-end some more text outer-end\n"
"outer-start some text inner-start text-that-i-want inner-end some more unwanted text outer-end\n")
matches = re.finditer(regex, test_str)
for matchNum, match in enumerate(matches, start=1):
print ("Match {matchNum} was found at {start}-{end}: {match}".format(matchNum = matchNum, start = match.start(), end = match.end(), match = match.group()))
for groupNum in range(0, len(match.groups())):
groupNum = groupNum + 1
print ("Group {groupNum} found at {start}-{end}: {group}".format(groupNum = groupNum, start = match.start(groupNum), end = match.end(groupNum), group = match.group(groupNum)))
# Note: for Python 2.7 compatibility, use ur"" to prefix the regex and u"" to prefix the test string and substitution.