const regex = /(?xs)
outer-start(?:(?!inner-start).)*?outer-end|
outer-start(?:(?!outer-end).)*?inner-end(?:(?!outer-end).)*?s\.*?outer-end|
inner-start\s*(text-that-i-want)\s*inner-end/g;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('(?xs)
outer-start(?:(?!inner-start).)*?outer-end|
outer-start(?:(?!outer-end).)*?inner-end(?:(?!outer-end).)*?s\\.*?outer-end|
inner-start\\s*(text-that-i-want)\\s*inner-end', 'g')
const str = `outer-start some unwanted text inner-start text-that-i-want inner-end some more text outer-end
outer-start some text inner-start text-that-i-want inner-end some more unwanted text outer-end
outer-start some text inner-start text-that-i-want inner-end some more text outer-end
outer-start some text inner-start text-that-i-want inner-end some more unwanted text outer-end
`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}