$re = '/(?xs)
outer-start(?:(?!inner-start).)*?outer-end|
outer-start(?:(?!outer-end).)*?inner-end(?:(?!outer-end).)*?s\.*?outer-end|
inner-start\s*(text-that-i-want)\s*inner-end/';
$str = 'outer-start some unwanted text inner-start text-that-i-want inner-end some more text outer-end
outer-start some text inner-start text-that-i-want inner-end some more unwanted text outer-end
outer-start some text inner-start text-that-i-want inner-end some more text outer-end
outer-start some text inner-start text-that-i-want inner-end some more unwanted text outer-end
';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);