import Foundation
let pattern = #"""
(?xs)
outer-start(?:(?!inner-start).)*?outer-end|
outer-start(?:(?!outer-end).)*?inner-end(?:(?!outer-end).)*?s\.*?outer-end|
inner-start\s*(text-that-i-want)\s*inner-end
"""#
let regex = try! NSRegularExpression(pattern: pattern)
let testString = #"""
outer-start some unwanted text inner-start text-that-i-want inner-end some more text outer-end
outer-start some text inner-start text-that-i-want inner-end some more unwanted text outer-end
outer-start some text inner-start text-that-i-want inner-end some more text outer-end
outer-start some text inner-start text-that-i-want inner-end some more unwanted text outer-end
"""#
let stringRange = NSRange(location: 0, length: testString.utf16.count)
let matches = regex.matches(in: testString, range: stringRange)
var result: [[String]] = []
for match in matches {
var groups: [String] = []
for rangeIndex in 1 ..< match.numberOfRanges {
let nsRange = match.range(at: rangeIndex)
guard !NSEqualRanges(nsRange, NSMakeRange(NSNotFound, 0)) else { continue }
let string = (testString as NSString).substring(with: nsRange)
groups.append(string)
}
if !groups.isEmpty {
result.append(groups)
}
}
print(result)