#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?im)^[a-z0-9]{2,}[a-z0-9.]*[a-z0-9]+$"
Local $sString = "+_#luke123*" & @CRLF & _
"john.green" & @CRLF & _
"luci.mayer89" & @CRLF & _
"admin" & @CRLF & _
"2 or more letters or numbers and end with 1 or more letters or numbers "
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")