using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"^[a-z0-9]{2,}[a-z0-9.]*[a-z0-9]+$";
string input = @"+_#luke123*
john.green
luci.mayer89
admin
2 or more letters or numbers and end with 1 or more letters or numbers ";
RegexOptions options = RegexOptions.IgnoreCase | RegexOptions.Multiline;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}