package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?im)^[a-z0-9]{2,}[a-z0-9.]*[a-z0-9]+$`)
var str = `+_#luke123*
john.green
luci.mayer89
admin
2 or more letters or numbers and end with 1 or more letters or numbers `
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}