import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "^[a-z0-9]{2,}[a-z0-9.]*[a-z0-9]+$";
final String string = "+_#luke123*\n"
+ "john.green\n"
+ "luci.mayer89\n"
+ "admin\n"
+ "2 or more letters or numbers and end with 1 or more letters or numbers ";
final Pattern pattern = Pattern.compile(regex, Pattern.CASE_INSENSITIVE | Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}