$re = '/^[a-z0-9]{2,}[a-z0-9.]*[a-z0-9]+$/im';
$str = '+_#luke123*
john.green
luci.mayer89
admin
2 or more letters or numbers and end with 1 or more letters or numbers ';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);